You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 108 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - BBtoNuke 2.0.21 to 2.0.22 "Invalid Session Problem'' [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
mike1985
Nuke Cadet
Nuke Cadet


Joined: Dec 18, 2006
Posts: 6


PostPosted: Tue Dec 26, 2006 7:12 am Reply with quoteBack to top

This is a heads up to nukecops for the following errors that show when the upgrade was made.

cannot post, cannot send private messages. all members admins and mods get this message in a box on top of the content they are viewing.

Quote:
Invalid Session. Please resubmit the form


I am running PHPNUKE 7.8 with BBtonuke 2.0.21
BBtoNuke Mods:
Birthday mod
Buddy List
Topic Description
Topic Ratings
Approval Mod
etc, etc, etc

I use Beyond Compare to help me upgrade the forum and site to a newer version all the time, and have done it in the past with great success. i guess i will just stick to BBtoNuke 2.0.21 for now. Smile

PS:
I do not know if i missed something before downloading this update, but i never noticed the post made in the announcement section that this update was not meant to be used for a production site Confused
Find all posts by mike1985View user's profileSend private message
sixf00t4
Sergeant
Sergeant


Joined: Oct 16, 2003
Posts: 123


PostPosted: Wed Dec 27, 2006 10:57 pm Reply with quoteBack to top

same thing here, ravennuke, no additional mods.

_________________
Legend of Six is an RPG, lots of fun.
free, no email registration required, text/browser based, lots of players, and looking for developers!
Find all posts by sixf00t4View user's profileSend private messageVisit poster's website
XenoMorpH
Lieutenant
Lieutenant


Joined: Aug 24, 2003
Posts: 187

Location: Coevorden, Netherlands

PostPosted: Thu Dec 28, 2006 10:13 am Reply with quoteBack to top

I'm not really good with sessions, but it seems to be that in posting.php
Code:
$hidden_form_fields .= '<input type="hidden" name="sid" value="' . $userdata['session_id'] . '" />';
which is beeing sent along with the posting. is different than the check:
Code:
if ($sid == '' || $sid != $userdata['session_id'])

So the check is always negative and the script will stop.

I replaced

Code:

   if ($sid == '' || $sid != $userdata['session_id'])
   {
      $error_msg .= (!empty($error_msg)) ? '<br />' . $lang['Session_invalid'] : $lang['Session_invalid'];
   }
with
Code:
   if ($sid == '' || $sid != $userdata['session_id'])
   {
      $error_msg .= '<br />'.$sid.'<br>'.$userdata['session_id'].'';
   }

Both values are different...
Does any1 has a solution for this?

_________________
http://www.tdi-hq.com
MSN- status: Image
Find all posts by XenoMorpHView user's profileSend private message
mike1985
Nuke Cadet
Nuke Cadet


Joined: Dec 18, 2006
Posts: 6


PostPosted: Thu Dec 28, 2006 6:19 pm Reply with quoteBack to top

Take note the problem also exists in the forum profile page, when ever someone tries to update there info, the same thing happens.

Thanks. Smile
Find all posts by mike1985View user's profileSend private message
FcUK_A
Nuke Cadet
Nuke Cadet


Joined: Oct 26, 2003
Posts: 2


PostPosted: Fri Dec 29, 2006 10:19 am Reply with quoteBack to top

Getting the same thing with my site after upgrade. I can post but i am admin, everyone else goes to post and the screen refreshes but says Invalid Session. Please resubmit the form.

Thanks

A.
Find all posts by FcUK_AView user's profileSend private message
FcUK_A
Nuke Cadet
Nuke Cadet


Joined: Oct 26, 2003
Posts: 2


PostPosted: Fri Dec 29, 2006 11:36 am Reply with quoteBack to top

And i have no mods bar the bb code one.

A.
Find all posts by FcUK_AView user's profileSend private message
Vanquish
Nuke Cadet
Nuke Cadet


Joined: Jan 01, 2007
Posts: 2


PostPosted: Mon Jan 01, 2007 10:26 am Reply with quoteBack to top

I am getting the same error.

I am running
PHP-Nuke Platinum 7.6.b.2
BBNuke 2.0.22 with no mods (only thing done was the fix group script)

Normal members get invalid session when trying to post or reply. They also can not send private messages

Administrators and Moderators of the forums can post, reply and send private messages. They do not get the message.

We do not get the profile page problem because we use PNC from phpnuke-clan
Find all posts by VanquishView user's profileSend private message
diveanx
Nuke Cadet
Nuke Cadet


Joined: Sep 06, 2003
Posts: 9

Location: Florida

PostPosted: Mon Jan 01, 2007 6:41 pm Reply with quoteBack to top

I got this message when i upgraded as well.

I am running Nuke version 7.9.3.2c. I posted this problem in the PCN site and Hammer and TCBnc have been trying to help out as well.

I ended up changing back to version.21 The only thing the upgrade does is change some files, the only database change it makes is to the version.

I just used my backup files to restore and then went into the database and eidt the bbconfig file to reflect version .21 and all my troubles were gone.

I even posted on the phpBB site and I was basically told it was my problem and they were not going to help
Find all posts by diveanxView user's profileSend private messageSend e-mailVisit poster's websiteAIM AddressICQ Number
WL
Nuke Cadet
Nuke Cadet


Joined: Jan 02, 2007
Posts: 1


PostPosted: Tue Jan 02, 2007 8:20 am Reply with quoteBack to top

I've got the same problem (Nuke 7.9 w/BBtoNuke2022). Some of our forum users report that the error appears in IE but not Firefox.
Find all posts by WLView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Thu Jan 04, 2007 6:08 pm Reply with quoteBack to top

Some have suggested making sure the cookies settings in your Forums Configuration are correct

I will look into the problems with BBToNuke 2.0.22

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Vanquish
Nuke Cadet
Nuke Cadet


Joined: Jan 01, 2007
Posts: 2


PostPosted: Sat Jan 06, 2007 1:52 pm Reply with quoteBack to top

This is what I learned from the guys over a www.phpnuke-clan.net


You have to change the cookie settings.

"I made new accounts, tried admins, groups, everything and i can post with all of them.

I have found that the cookie name itself doesn't need to be chnaged but you can change it if you want. The thing that really matters is the domain name. For sites in a sub-domain it has to be set like this "pnc4.phpnukeclan.net" and for a site like this one it has to be set to ".phpnuke-clan.net"(notice the dot in the begining). As for the cookie path if the site is not in a sub folder like "www.phpnuke-clan.net/html/" it shoudl be set to "/". Now if it is set in a sub folder or folders it has to be set to "/html/" (it need to fill in the gap between the domain name modules.php)."

I only know this works with there there package hope this helps.
Find all posts by VanquishView user's profileSend private message
stcloudscoots
Nuke Soldier
Nuke Soldier


Joined: Feb 03, 2006
Posts: 26


PostPosted: Sat Jan 06, 2007 4:47 pm Reply with quoteBack to top

That did not seem to work for me unless I am typing my cookie info wrong.
But thanks for the info. Any other ideas. I wish I could help solve the prob. but I have tried everything I can think of which is not much compared to some.

--------------------------------------------------------------------------------


Any more word on this any place?
Find all posts by stcloudscootsView user's profileSend private messageVisit poster's website
stcloudscoots
Nuke Soldier
Nuke Soldier


Joined: Feb 03, 2006
Posts: 26


PostPosted: Tue Jan 09, 2007 4:21 pm Reply with quoteBack to top

I was typing my cookie info wrong. No spaces in the cookie name
Find all posts by stcloudscootsView user's profileSend private messageVisit poster's website
sixf00t4
Sergeant
Sergeant


Joined: Oct 16, 2003
Posts: 123


PostPosted: Mon Jan 29, 2007 2:55 pm Reply with quoteBack to top

so I have 2 domain names used for the same site. I am only able to enter 1 domain name for the cookie, which means the forums are only accessible through that domain name else they get the invalid session. Am i stuck with having to edit the code to allow both sites?

_________________
Legend of Six is an RPG, lots of fun.
free, no email registration required, text/browser based, lots of players, and looking for developers!
Find all posts by sixf00t4View user's profileSend private messageVisit poster's website
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Mon Jan 29, 2007 10:16 pm Reply with quoteBack to top

Yes unfortunatly so

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.556 Seconds - 161 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::