You are missing our premiere tool bar navigation system! Register and use it for FREE!


Author: RavenLocation: USAPostPosted: Tue Sep 16, 2003 4:49 am    Post subject: Re: New User Activation not Working

The conversion script you use still has a tiny, but major flaw in it. It keeps the anonymous user -1. That will not work in the later release port. In addition to altering the autoincrement values, you must do this too.

- Change the -1 userid to 0 or (1 if 1 is not already used) in nuke_users.
- Using phpMyAdmin, change all poster_id from -1 to 0 (or 1) in nuke_bbposts.
- Using phpMyAdmin, change all topics_poster from -1 to 0 (or 1) in nuke_bbtopics.

There may be one more table/column, I can't remember for sure where there is the -1 that you will have to change. Maybe on replies.

It's the -1 that is causing the huge auto increment values.

Author: DeakoPostPosted: Tue Sep 16, 2003 5:11 am    Post subject:

I dont allow anonymous posting on the forum, and am unable to find any -1 values in the other tables. However, at the bottom of the nuke_users table the Next Autoindex is still listed as the stupidly high number after changing the anonymous user_id to 1.

Any other ideas? Can i force the autoincrement back to 236 like others have mentioned?

Author: RavenLocation: USAPostPosted: Tue Sep 16, 2003 5:23 am    Post subject:

Whether you allow it or not, the system usually adds an anonymous user in the nuke_users table with a -1 user_id. If you do not have a -1 user_id, that is very odd and I have never seen the huge number occur for any other reason. Try doing an SQL search on the table

Select * from nuke_users where user_id=-1;

to verify that there is no user like that. If there isn't, then I don't know what else would cause your problem.

Author: GuestPostPosted: Tue Sep 16, 2003 5:28 am    Post subject:

No, i have changed the user_id in the nuke_users table for the anonymous poster back to 1 from -1. However, because i dont allow any anonymous posting there are no other -1 values in the tables.

But the autoindex is still listed as:- 2147483647 at the bottom of the nuke_users table and upon creating new users they are given that user_id!

Author: RavenLocation: USAPostPosted: Tue Sep 16, 2003 5:31 am    Post subject:

Try this.

- Export the table and save it to a file. Manually alter the auto increment value in the exported file to 236.
- Drop the nuke_users table.
- Import the table back in.

Author: GuestPostPosted: Tue Sep 16, 2003 5:37 am    Post subject: Re: New User Activation not Working

Hehe, thats what im trying to find out how to do at the moment. I need to manually alter tha autoincrement but dont know how! Wink

Author: RavenLocation: USAPostPosted: Tue Sep 16, 2003 5:42 am    Post subject:

Use phpMyAdmin. Select the nuke_users table. Issue this command in the SQL window

ALTER TABLE nuke_users AUTO_INCREMENT = 236;

[syntax error - sorry - typo corrected]


Last edited by Raven on Tue Sep 16, 2003 5:47 am; edited 1 time in total

Author: GuestPostPosted: Tue Sep 16, 2003 5:45 am    Post subject:

Similar to the error i get above unfortunately. This is the error i get:-
NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 

Author: GuestPostPosted: Tue Sep 16, 2003 1:58 am    Post subject: Re: New User Activation not Working

Also, if i try to manually add a user to the database using the administration, then after i confirm the details im presented with a blank page with the admin.php address in the brower window! EEEk. Please help me if you can.

Author: GuestPostPosted: Tue Sep 16, 2003 2:18 am    Post subject: Re: New User Activation not Working

Ok then, due to my cast computer knowledge Wink I have discovered what is happening, i just dont know how to stop it!

When a new user is created, instead of incrementing by "1" the new user gets a user_id of "2147483647". Thats enough to screw up the new users registration process it seems.

Any ideas where the current or next user_id is stored, or how its worked out?? Really desperate for this information if anyone can help!!
Thanks in Advance!

Author: DeakoPostPosted: Tue Sep 16, 2003 3:22 am    Post subject:

Ok guys, really am desperate. I know what i need to do, but i just cant figure out how to do it.

Someone said goto phpmyadmin and look at the options for the nuke_users table and set the auto increment that way. However, once there the option isnt available.

Also, another suggestion was to try a small sql command:-

Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 378 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - New User Activation not Working New User Activation not Working

Nuke Cops -> Post-Install Help For Guests Only

Author: Deako PostPosted: Tue Sep 16, 2003 1:56 am    Post subject: New User Activation not Working

Hi all, please help with with this query asap if possible.

I have recently undertaken a phpBB to nuke port which went well. Im running the 2.0.6 version of the BB integrated with the Nuke site. This is all working well, i have also carried out the quick reply mod on the forum and this has also worked well.

Up until a couple of days back (i have carried out so many mods now i lose track of them) the new user registration was functioning correctly. However, now it doesnt appear to be working.

When the new user gets the confirmation email, they click the link only to be told the account has been created. However, when they try to log on they are told that the login information is incorrect. Also, if they try clicking on the email link again, they are told the account also doesnt exist.

Im running version 6.5 of PHP Nuke.

Any help would be appreciated, or i feel im going to have to restore an older version that i have backed up and hope there are no DB conflicts!
Quote:

ALTER TABLE nuke_users AUTO_INCREMENT = 236;
ALTER TABLE nuke_users_temp AUTO_INCREMENT = 236;

^^^^236 is what i need my records to start from.

But i get the following error:-

Quote:

SQL-query :

ALTER TABLE nuke_usersAUTO_INCREMENT = 236

MySQL said:


You have an error in your SQL syntax near '= 236' at line 1


Here is the information listed at the bottom of my nuke_users table:-

Quote:

Row Statistic : Statements Value
Format dynamic
Rows 233
Row length 271
Row size 346 Bytes
Next Autoindex 2,147,483,647


Can anyone else help me reset the auto increment to my pre determined value?
Quote:

Error

SQL-query :

ALTER TABLE nuke_users SET AUTO_INCREMENT = 236

MySQL said:


You have an error in your SQL syntax near 'SET AUTO_INCREMENT = 236' at line 1
Back


Thanks for all the help btw. Any other ideas?

Author: RavenLocation: USA PostPosted: Tue Sep 16, 2003 5:50 am    Post subject:

The SET was a mistake. Try this.

Make sure that you have corrected the high number to a valid number. Then issue
ALTER TABLE nuke_users AUTO_INCREMENT = 236;

Author: Guest PostPosted: Tue Sep 16, 2003 5:52 am    Post subject:

As i listed above, this is the code i found somewhere else and it didnt work. Well not with my phpmyadmin anyway Sad

Error i get is the same as above:-
Quote:

Error

SQL-query :

ALTER TABLE nuke_usersAUTO_INCREMENT = 236

MySQL said:


You have an error in your SQL syntax near '= 236' at line 1

Author: RavenLocation: USA PostPosted: Tue Sep 16, 2003 5:55 am    Post subject:

Raven wrote:
Try this.

- Export the table and save it to a file. Manually alter the auto increment value in the exported file to 236.
- Drop the nuke_users table.
- Import the table back in.


Then do what I told you in this post. Manually alter the value in the FILE with a text editor. The drop the table using phpMyAdmin. Then IMPORT the table back in.

Author: Guest PostPosted: Tue Sep 16, 2003 5:55 am    Post subject:

NOTE:- i didnt remove the space between users and AUTO, but for some reason it takes it out.

Author: Guest PostPosted: Tue Sep 16, 2003 6:00 am    Post subject: Re: New User Activation not Working

Code:
# phpMyAdmin MySQL-Dump
# version 2.3.3pl1
# http://www.phpmyadmin.net/ (download page)
#
# Host: localhost
# Generation Time: Sep 16, 2003 at 03:02 PM
# Server version: 3.23.37
# PHP Version: 4.1.2
# Database : `nuke`
# --------------------------------------------------------

#
# Table structure for table `nuke_users`
#

CREATE TABLE nuke_users (
  user_id int(11) NOT NULL auto_increment,
  name varchar(60) NOT NULL default '',
  username varchar(25) NOT NULL default '',
  user_email varchar(255) NOT NULL default '',
  femail varchar(255) NOT NULL default '',
  user_website varchar(255) NOT NULL default '',
  user_avatar varchar(255) NOT NULL default '',
  user_regdate varchar(20) NOT NULL default '',
  user_icq varchar(15) default NULL,
  user_occ varchar(100) default NULL,
  user_from varchar(100) default NULL,
  user_interests varchar(150) NOT NULL default '',
  user_sig varchar(255) default NULL,
  user_viewemail tinyint(2) default NULL,
  user_theme int(3) default NULL,
  user_aim varchar(18) default NULL,
  user_yim varchar(25) default NULL,
  user_msnm varchar(25) default NULL,
  user_password varchar(40) NOT NULL default '',
  storynum tinyint(4) NOT NULL default '10',
  umode varchar(10) NOT NULL default '',
  uorder tinyint(1) NOT NULL default '0',
  thold tinyint(1) NOT NULL default '0',
  noscore tinyint(1) NOT NULL default '0',
  bio tinytext NOT NULL,
  ublockon tinyint(1) NOT NULL default '0',
  ublock tinytext NOT NULL,
  theme varchar(255) NOT NULL default '',
  commentmax int(11) NOT NULL default '4096',
  counter int(11) NOT NULL default '0',
  newsletter int(1) NOT NULL default '0',
  user_posts int(10) NOT NULL default '0',
  user_attachsig int(2) NOT NULL default '0',
  user_rank int(10) NOT NULL default '0',
  user_level int(10) NOT NULL default '1',
  broadcast tinyint(1) NOT NULL default '1',
  popmeson tinyint(1) NOT NULL default '0',
  user_active tinyint(1) default '1',
  user_session_time int(11) NOT NULL default '0',
  user_session_page smallint(5) NOT NULL default '0',
  user_lastvisit int(11) NOT NULL default '0',
  user_timezone tinyint(4) NOT NULL default '10',
  user_style tinyint(4) default NULL,
  user_lang varchar(255) NOT NULL default 'english',
  user_dateformat varchar(14) NOT NULL default 'D M d, Y g:i a',
  user_new_privmsg smallint(5) unsigned NOT NULL default '0',
  user_unread_privmsg smallint(5) unsigned NOT NULL default '0',
  user_last_privmsg int(11) NOT NULL default '0',
  user_emailtime int(11) default NULL,
  user_allowhtml tinyint(1) default '1',
  user_allowbbcode tinyint(1) default '1',
  user_allowsmile tinyint(1) default '1',
  user_allowavatar tinyint(1) NOT NULL default '1',
  user_allow_pm tinyint(1) NOT NULL default '1',
  user_allow_viewonline tinyint(1) NOT NULL default '1',
  user_notify tinyint(1) NOT NULL default '0',
  user_notify_pm tinyint(1) NOT NULL default '0',
  user_popup_pm tinyint(1) NOT NULL default '0',
  user_avatar_type tinyint(4) NOT NULL default '3',
  user_sig_bbcode_uid varchar(10) default NULL,
  user_actkey varchar(32) default NULL,
  user_newpasswd varchar(32) default NULL,
  user_group_cp int(11) NOT NULL default '2',
  user_active_cp enum('YES','NO') NOT NULL default 'YES',
  user_lastvisit_cp datetime NOT NULL default '0000-00-00 00:00:00',
  user_regdate_cp datetime NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (user_id),
  KEY uid (user_id),
  KEY uname (username),
  KEY user_session_time (user_session_time),
  KEY user_session_time_2 (user_session_time)
) TYPE=MyISAM;


The Autoincrement value is not set in this table anywhere. What follows this code is just the list of users which ends on 235 at present.

Author: RavenLocation: USA PostPosted: Tue Sep 16, 2003 6:05 am    Post subject:

Modify the last line from
TYPE=MyISAM;
to
TYPE=MyISAM AUTO_INCREMENT=236;

If that errs, thenyou may need to update your version of phpMyAdmin because the syntax is correct.

Author: Guest PostPosted: Tue Sep 16, 2003 6:12 am    Post subject:

I think i love you and want you to have my children! It worked! Very Happy

Author: RavenLocation: USA PostPosted: Tue Sep 16, 2003 6:39 am    Post subject:

Please, Please, assure me that you are a female Laughing

Author: Guest PostPosted: Tue Sep 16, 2003 6:42 am    Post subject:

Sorry, im male, i was hoping the same as well. Nevermind, if i was gay id want to share some brother love with you! Razz

But as im not, ill just say thanks! Very Happy

Author: RavenLocation: USA PostPosted: Tue Sep 16, 2003 7:51 am    Post subject:

And I will just say You're Welcome!

Author: DrScaresLocation: Chicago PostPosted: Sat Oct 25, 2003 10:22 am    Post subject: Re: New User Activation not Working

Interestingly enough, I'm suffering from this exact problem. The interesting thing is that my auto increment number for the user_id field is exactly the same as mentioned above.

What happened with me is I had to migrate a stand alone PHPBB2 board into the empty shell in PHPNuke 6.9.

After I did so, whenever a new user would attempt to register, in the Table, it would set their user_id as that ridiculous 217.... number so no one else could register. I read on another forum that someone else also had this problem who migrated their forums. The script I was using is from the Nuke UK website that can be found on that site.

I couldn't find how to switch the auto_increment, and I can't wait to try this method. So thanks for that Raven.

Here's my question though. What process of porting over data from two tables would result in the user_id being set to this number?

Author: RavenLocation: USA PostPosted: Sat Oct 25, 2003 11:32 am    Post subject: Re: New User Activation not Working

Here is one thread on my site that discusses this. There are others. It's a result of anonymous users having an id of -1. Hope this helps.

http://ravenphpscripts.com/posts280-highlightphpbb.html+increment

Author: Deako PostPosted: Wed Nov 05, 2003 4:28 pm    Post subject: Re: New User Activation not Working

DrScares wrote:
Interestingly enough, I'm suffering from this exact problem. The interesting thing is that my auto increment number for the user_id field is exactly the same as mentioned above.

What happened with me is I had to migrate a stand alone PHPBB2 board into the empty shell in PHPNuke 6.9.

After I did so, whenever a new user would attempt to register, in the Table, it would set their user_id as that ridiculous 217.... number so no one else could register. I read on another forum that someone else also had this problem who migrated their forums. The script I was using is from the Nuke UK website that can be found on that site.

I couldn't find how to switch the auto_increment, and I can't wait to try this method. So thanks for that Raven.

Here's my question though. What process of porting over data from two tables would result in the user_id being set to this number?


Did you sort your problem out? My forum has worked a treat since!

Author: DrScaresLocation: Chicago PostPosted: Wed Nov 05, 2003 8:54 pm    Post subject: Re: New User Activation not Working

Yeah it ended up working! The only thing now is the memberlist data isn't sorted correctly, its all fudged up. Why? I don't know. But it won't sort correctly. Look here too see what I mean:

http://24.148.21.33:8080/main/modules.php?name=Members_List

Author: SaintPeter PostPosted: Mon Nov 10, 2003 4:18 pm    Post subject: Re: New User Activation not Working

Bless you, Bless you all!

My Problem:
After an upgrade from phpBB to phpNuke, no new users could add.
The issue was that the "Autoindex" was set to 2147483647, the maximum value for (11*Cool^2. No new members could add once a user had the highest possible index.

Solution:
First, the "Anonymous" user has a user_id of -1. In "Twos complement", that is the same as the highest possible number in unsigned. So, you have to change this user_id to be 0 or 1. You also have to do this for the nuke_user_groups table as well.
Then, you can do this SQL command:
alter table `nuke_users` auto_increment = #

You must replace # with the current highest user_id+1
In my case, the line looked like this:
alter table `nuke_users` auto_increment = 720

Your milage may vary.

Thanks for the great insight. Thought I was going crazy.

Author: Import PostPosted: Mon Nov 10, 2003 5:23 pm    Post subject: Re: New User Activation not Working

Im so confused..

http://www.usefcentral.net

I only have 6 users------
I changed TYPE=MyISAM AUTO_INCREMENT=9;

Max. number of accounts: -1

Now they get the activation then they click on it, it then goes to the home page but it's messed up and they still can't log in!


http://www.usefcentral.net/modules.php?name=Your_Account&op=activate&username=how&check_num=65a1fe245c2acebb361bfeeea49504ae


Iv tryed everything, i changed my Anonymous user id to 0.

But the user_id are messed up i think they skip #'s

Anonymous = 0
TK = 2
|ce = 4
BRAVO2 = 5
[IE] BIG LOU DOG = 6
Cataclysm = 7
AGM130 = 8

Author: mjrwoody PostPosted: Fri Nov 14, 2003 12:30 pm    Post subject: Re: New User Activation not Working

SaintPeter wrote:
Bless you, Bless you all!
Solution:
First, the "Anonymous" user has a user_id of -1. In "Twos complement", that is the same as the highest possible number in unsigned. So, you have to change this user_id to be 0 or 1. You also have to do this for the nuke_user_groups table as well.
Then, you can do this SQL command:
alter table `nuke_users` auto_increment = #

You must replace # with the current highest user_id+1
In my case, the line looked like this:
alter table `nuke_users` auto_increment = 720


Same issue here. I don't use nuke user groups, so i didn't have that table. Also, for newbies like me, in phpMyAdmin click on "nuke_users" then on "Operations", scroll to the bottom and change your "auto_increment" value here then click on "go"

Author: Death_of_Thought PostPosted: Wed Dec 03, 2003 2:08 am    Post subject: Re: New User Activation not Working

I have the same damned problem... however I cannot access PHPMYADMIN thingy, I use a modem.... could it just be the connection speed.... ? anyway I usually recieve an average of 2 new users per day, however nobody can register and thus at such a vital time in the site's life I need to fix this ASAP, okay now for the question: is there another way other than via phpmyadmin?

can I backup the database via the admin control panel and then edit it locally and then restore the backup?

I really need any help this is the first topic that I have found which describes my exact problem. I have nuke 6.9 I converted with the PHPBB to nuke script... I also have various other problems.

Is there a script for this or any alternatives?

Author: Death_of_Thought PostPosted: Fri Dec 05, 2003 4:29 am    Post subject: Re: New User Activation not Working

don't worry I got access to phpmyadmin and fixed it
thanks for the help I just followed the instructions above and now all is well

Author: Guest PostPosted: Sat Dec 06, 2003 6:18 am    Post subject: Re: New User Activation not Working

Would it be because you're missing the ";" at the end of your statement?

Author: Guest PostPosted: Sun Jan 11, 2004 9:41 pm    Post subject:

Raven wrote:
Modify the last line from
TYPE=MyISAM;
to
TYPE=MyISAM AUTO_INCREMENT=236;

If that errs, thenyou may need to update your version of phpMyAdmin because the syntax is correct.


For some reason if I try to edit this line it always deletes it when it is omported.

What's up with that

Author: cujoac PostPosted: Mon Jan 12, 2004 1:51 am    Post subject: Re: New User Activation not Working

Ok, i had the same problem, but i've nuetralized it to another issue. My users were having trouble authorizing their registration, the reason is because the address that the confirmation email is sending out is this:

Quote:
http://charlow.com/stl-web/portal/cms/index.php/modules.php?name=Your_Account&op=activate&username=CujoAC&check_num=3f703b566f191274db984c4a148931ae


Don't worry about the user, it is a fake one i set up. Anyways, you'll notice that it says index.php/modules.php. If i delete the index.php from the link, everything works fine.........BUT, i don't want to have to tell every new user that. Is there a way to correct the error before it gets sent out in the email?

Author: Guest PostPosted: Tue Jan 27, 2004 12:02 pm    Post subject: Re: New User Activation not Working

I too am having this same problem as
cujoac
Quote:
Don't worry about the user, it is a fake one i set up. Anyways, you'll notice that it says index.php/modules.php. If i delete the index.php from the link, everything works fine.........BUT, i don't want to have to tell every new user that. Is there a way to correct the error before it gets sent out in the email?


How can we get rid of the index.php before the"/modules"

Thanks[/quote]

Author: RavenLocation: USA PostPosted: Tue Jan 27, 2004 12:47 pm    Post subject:

Check your nuke Preferences Site URL setting. That is what is prefixed to all relative paths. My guess would be that it reads
Code:
http://charlow.com/stl-web/portal/cms/index.php
and it should read
Code:
http://charlow.com/stl-web/portal/cms
This has been addressed probably several hundred times in these forums. Also, in your Forum Administration Configuration, your domain name should be
Code:
charlow.com/stl-web/portal/cms

Author: sami94 PostPosted: Wed Oct 26, 2005 9:02 pm    Post subject: Re: New User Activation not Working

i dont now what to do now.!

Author: Evaders99 PostPosted: Wed Oct 26, 2005 9:35 pm    Post subject: Re: New User Activation not Working

Please explain your problem better so we can help you.



Nuke Cops -> Post-Install Help For Guests Only

All times are GMT - 8 Hours

Page 1 of 1

Powered by phpBB © 2001,2002 phpBB Group
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.676 Seconds - 139 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
added by Evaders - DO NOT REMOVE
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::