You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 415 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - Unable to add news to the site [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Wed Sep 14, 2005 5:13 am Reply with quoteBack to top

I'm having a strange problem.
When I write in the news, I it the submit button then I go to the news section and there's no update. Anyone has any hint about the cause for this problem?
Database problem? How can I re-install that module?

Thanks
Find all posts by kampuzView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Sep 14, 2005 11:00 am Reply with quoteBack to top

Most likely a database problem. Is this a new installation or an upgrade? What phpNuke version are you using?

Use phpMyAdmin and post the structure of your stories tables

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Wed Sep 14, 2005 1:53 pm Reply with quoteBack to top

It's an upgrade. The version that I'm using is the 7.7 patched.

Here is the structure of my structures table

Code:
CREATE TABLE `nuke_stories` (
  `sid` int(11) NOT NULL auto_increment,
  `catid` int(11) NOT NULL default '0',
  `aid` varchar(30) NOT NULL default '',
  `title` varchar(80) default NULL,
  `time` datetime default NULL,
  `hometext` text,
  `bodytext` text NOT NULL,
  `comments` int(11) default '0',
  `counter` mediumint(8) unsigned default NULL,
  `topic` int(3) NOT NULL default '1',
  `informant` varchar(20) NOT NULL default '',
  `notes` text NOT NULL,
  `ihome` int(1) NOT NULL default '0',
  `alanguage` varchar(30) NOT NULL default '',
  `acomm` int(1) NOT NULL default '0',
  `haspoll` int(1) NOT NULL default '0',
  `pollID` int(10) NOT NULL default '0',
  `score` int(10) NOT NULL default '0',
  `ratings` int(10) NOT NULL default '0',
  `rating_ip` varchar(15) default '0',
  `associated` text NOT NULL,
  PRIMARY KEY  (`sid`),
  KEY `sid` (`sid`),
  KEY `catid` (`catid`),
  KEY `counter` (`counter`),
  KEY `topic` (`topic`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=85 ;


The rest of the site works fine
Thanks
Find all posts by kampuzView user's profileSend private message
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Fri Sep 16, 2005 3:00 pm Reply with quoteBack to top

Can anyone tell me please if the problem is from the database?

Thanks very much!
Find all posts by kampuzView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Fri Sep 16, 2005 3:29 pm Reply with quoteBack to top

Database seems fine - have you enabled error reporting and checked your error logs?

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Sat Sep 17, 2005 6:10 pm Reply with quoteBack to top

I have enabled the error reporting and nothing happened.

If it's not a db problem, maybe some corrupted file. Which files should I replace?

Thanks
Find all posts by kampuzView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Sat Sep 17, 2005 7:48 pm Reply with quoteBack to top

Just delete and reload your modules/News files

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Sun Sep 18, 2005 2:40 pm Reply with quoteBack to top

I tried to replace the old module for a new one (from the version 7.6 patched) and I still have the same problem. Are there other files that need to be checked?

I thinking on a fresh install... at least I think it would fix this problem.

Any more hints?

Thanks for your time and support!
Find all posts by kampuzView user's profileSend private message
jib_intelli
Captain
Captain


Joined: Jun 10, 2004
Posts: 338

Location: Lucknow, India

PostPosted: Sun Sep 18, 2005 8:22 pm Reply with quoteBack to top

I am also having the same problem on PHPNuke 7.8. Here are my Nuke_Stories tables:

Code:
--
-- Table structure for table `nuke_stories`
--

CREATE TABLE `nuke_stories` (
  `sid` int(11) NOT NULL auto_increment,
  `catid` int(11) NOT NULL default '0',
  `aid` varchar(25) NOT NULL default '',
  `title` varchar(80) default NULL,
  `time` datetime default NULL,
  `hometext` text,
  `bodytext` text NOT NULL,
  `comments` int(11) default '0',
  `counter` mediumint(8) unsigned default NULL,
  `topic` int(3) NOT NULL default '1',
  `informant` varchar(25) NOT NULL default '',
  `notes` text NOT NULL,
  `ihome` int(1) NOT NULL default '0',
  `alanguage` varchar(30) NOT NULL default '',
  `acomm` int(1) NOT NULL default '0',
  `haspoll` int(1) NOT NULL default '0',
  `pollID` int(10) NOT NULL default '0',
  `score` int(10) NOT NULL default '0',
  `ratings` int(10) NOT NULL default '0',
  `associated` text NOT NULL,
  PRIMARY KEY  (`sid`),
  KEY `sid` (`sid`),
  KEY `catid` (`catid`),
  KEY `counter` (`counter`),
  KEY `topic` (`topic`)
) TYPE=MyISAM AUTO_INCREMENT=131 ;


Please can someone help me on this? Also the usergroups dont work somehow Rolling Eyes

_________________
It is not our abilities which decide what we truly are, it is our choices.

Image
Find all posts by jib_intelliView user's profileSend private messageVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Mon Sep 19, 2005 11:03 am Reply with quoteBack to top

jib_intelli, you are missing the field 'rating_ip'
Did you run the upgrade script?

Code:

ALTER TABLE nuke_stories ADD rating_ip VARCHAR( 15 ) DEFAULT '0' AFTER ratings

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Mon Sep 19, 2005 11:12 am Reply with quoteBack to top

I replaced all the files that I had on the site with a fresh installation from the version 7.6. Then I added the 7.6 patched over it.

I still can't post anything on the news! Are you sure it isn't a db problem?
Thanks
Find all posts by kampuzView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Mon Sep 19, 2005 11:28 am Reply with quoteBack to top

It is if your database is 7.7, but your files are 7.6.

Your problem will be exactly the opposite, you need to delete the 'rating_ip' field

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
kampuz
Private
Private


Joined: Dec 13, 2004
Posts: 43


PostPosted: Mon Sep 19, 2005 2:56 pm Reply with quoteBack to top

It worked!!!

How can I pay you???

Thank u very much!!!

Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy
Find all posts by kampuzView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Mon Sep 19, 2005 9:10 pm Reply with quoteBack to top

I have a Paypal link on my site - http://evaders.swrebellion.com
Feel free to donate Smile

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
jib_intelli
Captain
Captain


Joined: Jun 10, 2004
Posts: 338

Location: Lucknow, India

PostPosted: Mon Sep 19, 2005 11:13 pm Reply with quoteBack to top

Oh wonderful!!! BTW, Evaders let me know how do I get my Usergroups to work? My problem is that Admins cannot administer the usergroups. Any help on that one?

_________________
It is not our abilities which decide what we truly are, it is our choices.

Image
Find all posts by jib_intelliView user's profileSend private messageVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.054 Seconds - 275 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::