You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 276 guest(s) and 13 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - Users and Forum data problem [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Wed Feb 11, 2009 4:56 pm Reply with quoteBack to top

ok...I've reinstalled my original db and was at 2.0.21 for both phpbb and phpnuke I ran the phpbb2phpnuke and both showed at the same rev. level. I am running phpnuke 8.0

I am attempting to import forums db from a free host to the new site and am getting this msg when I run the phpbb2phpnuke script now:

phpBB2phpNuke - a database converter from phpBB to phpNuke
by Evaders99 (http://evaders.swrebellion.com)


Dumping previous phpNuke users data


Inserting phpBB users data into phpNuke
Error inserting data from nuke_users to phoenixcries_users - Duplicate entry '1' for key 1


Updating phpNuke users user_level


Updating phpNuke users user_regdate


Dumping previous forums data


Reseting phpNuke bad banlist table structure (Not critical, don't worry if errors)


Reseting phpNuke bad ranks table structure (Not critical, don't worry if errors)


Inserting phpBB forums data into phpNuke
Error inserting data from phoenixcries_auth_access to nuke_bbauth_access - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_forums to nuke_bbforums - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_groups to nuke_bbgroups - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_posts to nuke_bbposts - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_privmsgs to nuke_bbprivmsgs - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_topics to nuke_bbtopics - Column count doesn't match value count at row 1


Reseting phpNuke default_style


Reseting phpNuke smilies path


Reseting phpNuke anonymous posts


Reseting gzip compress settings


Emptying phpNuke session data
DONE!

Any errors, you will need to use phpMyAdmin to export those tables manually.
Remember to edit your config values through the forums admin panel.
Please delete these files you uploaded from your server.


Not sure how to solve this problem, as I'm not familiar with how to fix it manually. Any help would be great with this, and if I have to pay for some help at this point I may be willing to do so.
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Feb 11, 2009 5:52 pm Reply with quoteBack to top

Basically your tables here must match
Code:

Error inserting data from phoenixcries_auth_access to nuke_bbauth_access - Column count doesn't match value count at row 1
...


Use phpMyAdmin to look at the structure of the first table 'phoenixcries_auth_access' and match to the second 'nuke_bbauth_access'

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Wed Feb 11, 2009 6:26 pm Reply with quoteBack to top

ok, I am looking at that and under the table there is a area titled "Indexes" and it is showing a group_id and a forum_id and they both have a value in the "Cardinality" field where my nuke_bbauth_access table does not.
Could this be the problem, and if so, I'm not sure exactly how to change the "cardinality" or which table I should change, the old one, or the one I'm moving the old one into.
There is also an extra row auth_downloads in the old one, I removed that one and it didn't help.
I've removed the tables that I had imported so I'm back to just my nuke_ tables now....not sure now where to go with it.

The reason for us moving away from the previous free forums is that a person ended up with a virus because of all of the flash ads that where on the site. So this should be much safer on our own ad free site, they had to totaly wipe their pc and reinstall.
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Feb 11, 2009 8:59 pm Reply with quoteBack to top

Code:
There is also an extra row auth_downloads in the old one, I removed that one and it didn't help.


I'm thinking you mean column, in which case.. yes, that's what you need to do. Rows generally represent entries of data (when you click Browse), while Columns represent the table structure itself. Make sure all the columns are the same between the phpBB2 and Nuke tables

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Wed Feb 11, 2009 9:31 pm Reply with quoteBack to top

ok, Did like you said and dropped that column again and I am getting this now:

phpBB2phpNuke - a database converter from phpBB to phpNuke
by Evaders99 (http://evaders.swrebellion.com)


Dumping previous phpNuke users data


Inserting phpBB users data into phpNuke
Error inserting data from nuke_users to phoenixcries_users - Duplicate entry '1' for key 1


Updating phpNuke users user_level


Updating phpNuke users user_regdate


Dumping previous forums data


Reseting phpNuke bad banlist table structure (Not critical, don't worry if errors)
Error reseting phpNuke bad nuke_bbbanlist table structure - Can't DROP 'ban_time'; check that column/key exists


Reseting phpNuke bad ranks table structure (Not critical, don't worry if errors)
Error reseting phpNuke bad nuke_bbranks table structure - Can't DROP 'rank_max'; check that column/key exists


Inserting phpBB forums data into phpNuke
Error inserting data from phoenixcries_forums to nuke_bbforums - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_groups to nuke_bbgroups - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_posts to nuke_bbposts - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_privmsgs to nuke_bbprivmsgs - Column count doesn't match value count at row 1
Error inserting data from phoenixcries_topics to nuke_bbtopics - Column count doesn't match value count at row 1


Reseting phpNuke default_style


Reseting phpNuke smilies path


Reseting phpNuke anonymous posts


Reseting gzip compress settings


Emptying phpNuke session data
DONE!

Any errors, you will need to use phpMyAdmin to export those tables manually.
Remember to edit your config values through the forums admin panel.
Please delete these files you uploaded from your server.

There seems to be several columns that are not in one that are in the other. Do I add those, or drop those, whichever the case may be?
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Wed Feb 11, 2009 10:32 pm Reply with quoteBack to top

Correct, add/drop as necessary. phpNuke generally uses the original table structure with no modifications. Thus any table changes from phpBB mods will need to be cleaned.

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Thu Feb 12, 2009 10:22 am Reply with quoteBack to top

Thanks for the help! I've got all of it imported successfully now, 1 more question though.
On the main page, the "visitor" block, is there a way to get the forum users imported in to where they can login using that block? I go to the site admin.php and try to do a search in the users module for a member, any member, and it doesn't come up with a user, however, they are listed in the forums. When a user tries to log into the forums on the forums page it gives this 404 error :
The requested URL /modules.php was not found on this server.
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Thu Feb 12, 2009 5:41 pm Reply with quoteBack to top

I'm not sure what you're referring to. The Your_Account module should handle all the logins. If something is attempting to login through the forums module itself, it needs to be removed or redirected.

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Thu Feb 12, 2009 7:19 pm Reply with quoteBack to top

Actually I'm not too sure what is going on with it.

Before I moved the free forums over into the new one, the new one had only 1 reg. user account set up. That one is gone now that I've moved the free forums tables in, I still have my admin account though.

In the admin section of the site if I click on the "users" module and try to search for a user, it comes back with nothing (even though I have imported 184 users), the user doesn't exist.
I can log into the forums at the forums page, down at the bottom there is a login, I can do it there, the problem with that is it won't let me log out, it keeps me logged in, even though it tells me I've logged out.
If I'm logged into the forums, it doesn't show I'm logged in on the main index.php page of the site in the visitors block like it should. It worked before I moved the db tables into the new site, now it does not, and will not let me log in using that block either.
Could this be an issue with improper cookie settings now with the imported db files?

Hopefully this explanation will be better than my previous one.
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Thu Feb 12, 2009 9:46 pm Reply with quoteBack to top

Assuming your website link is one you're concerned about, I don't see anything wrong.

Remove the login/logout links from the forums template, they won't work correctly.

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Thu Feb 12, 2009 10:21 pm Reply with quoteBack to top

Yes, that is the site. I've removed the log in section from the forums template, still same issue though. Using MySQL 5.0 also.

The problem is the users that where imported cannot log in now, just keeps going to the "Login Incorrect! Please Try Again..." page.
I can still log in using the admin account though.
When I setup the site I had a regular user created also with the admin account. That reg. user account is gone now, no big deal, but I was able to log in with that account before I had imported the other tables into the db. It used to show in the "visitors" block the name of the account. Now when I try to log in it just goes to the "Login Incorrect! Please Try Again..." page for any user that tries.

Just to experiment, I registered a test account, it let me sign up, sent me the confirmation email, I clicked the link to complete the registration, all was fine. I tried to log in and got the "Login Incorrect! Please Try Again..." page.
I then went to the admin page for the site and clicked on the "users" module and did a search for the test account. I got this message "User Doesn't Exists!"

ok, after I posted the above, I did find this post:
http://nukecops.com/postp216198.html#216198
so I tried what you had in that, I did not have the ublock or bio so I added those to the nuke_users. My test account then showed up in the "visitors" block, still not able to log in, but at least it is showing up as a newest member.

oh, just read some other posts, in nuke_users my Anonymous user_id is 1, is that correct, or does that need to be changed?

Hope this additional info may help out.
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Fri Feb 13, 2009 1:20 pm Reply with quoteBack to top

I was going through the db I imported and found this, you may be able to figure this out, I'm not sure, but it looks like Anonymous has two diff. settings that got imported:

LOCK TABLES `phoenixcries_users` WRITE;
INSERT INTO `phoenixcries_users` VALUES (-1,0,'Anonymous','',1234233474,0,1234232657,1202616427,0,0,'0.00',NULL,'','',0,0,0,0,0,NULL,0,0,1,1,1,1,0,1,0,1,0,NULL,'',0,'','','','','',NULL,'','','','','','','','12342316','42f947f1','460f8b67',1234233474,1602073,7858,5824,0,0,0,0,0),

LOCK TABLES `phoenixcries_groups` WRITE;
INSERT INTO `phoenixcries_groups` VALUES (1,1,'Anonymous','Personal User',0,1,0,0)
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Fri Feb 13, 2009 7:23 pm Reply with quoteBack to top

Anonymous should be user_id = 1 in phpNuke
Other than that, see no reason why it shouldn't work

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Bon3head
Nuke Soldier
Nuke Soldier


Joined: Aug 04, 2003
Posts: 32

Location: Indiana

PostPosted: Fri Feb 13, 2009 7:29 pm Reply with quoteBack to top

I have no idea then why it's not letting me log into the site as a normal user, it makes no sense to me.
What would you charge to take a look at it?
Find all posts by Bon3headView user's profileSend private messageVisit poster's websiteICQ Number
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Fri Feb 13, 2009 9:23 pm Reply with quoteBack to top

I'll talk to you via PM

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.113 Seconds - 305 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::