You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 441 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - New User Activation not Working [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
This forum is locked: you cannot post, reply to, or edit topics.  This topic is locked: you cannot edit posts or make replies.printer-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
Guest







PostPosted: Tue Sep 16, 2003 5:55 am Reply with quoteBack to top

NOTE:- i didnt remove the space between users and AUTO, but for some reason it takes it out.
Find all posts by Anonymous
Guest







PostPosted: Tue Sep 16, 2003 6:00 am Reply with quoteBack to top

Code:
# phpMyAdmin MySQL-Dump
# version 2.3.3pl1
# http://www.phpmyadmin.net/ (download page)
#
# Host: localhost
# Generation Time: Sep 16, 2003 at 03:02 PM
# Server version: 3.23.37
# PHP Version: 4.1.2
# Database : `nuke`
# --------------------------------------------------------

#
# Table structure for table `nuke_users`
#

CREATE TABLE nuke_users (
  user_id int(11) NOT NULL auto_increment,
  name varchar(60) NOT NULL default '',
  username varchar(25) NOT NULL default '',
  user_email varchar(255) NOT NULL default '',
  femail varchar(255) NOT NULL default '',
  user_website varchar(255) NOT NULL default '',
  user_avatar varchar(255) NOT NULL default '',
  user_regdate varchar(20) NOT NULL default '',
  user_icq varchar(15) default NULL,
  user_occ varchar(100) default NULL,
  user_from varchar(100) default NULL,
  user_interests varchar(150) NOT NULL default '',
  user_sig varchar(255) default NULL,
  user_viewemail tinyint(2) default NULL,
  user_theme int(3) default NULL,
  user_aim varchar(18) default NULL,
  user_yim varchar(25) default NULL,
  user_msnm varchar(25) default NULL,
  user_password varchar(40) NOT NULL default '',
  storynum tinyint(4) NOT NULL default '10',
  umode varchar(10) NOT NULL default '',
  uorder tinyint(1) NOT NULL default '0',
  thold tinyint(1) NOT NULL default '0',
  noscore tinyint(1) NOT NULL default '0',
  bio tinytext NOT NULL,
  ublockon tinyint(1) NOT NULL default '0',
  ublock tinytext NOT NULL,
  theme varchar(255) NOT NULL default '',
  commentmax int(11) NOT NULL default '4096',
  counter int(11) NOT NULL default '0',
  newsletter int(1) NOT NULL default '0',
  user_posts int(10) NOT NULL default '0',
  user_attachsig int(2) NOT NULL default '0',
  user_rank int(10) NOT NULL default '0',
  user_level int(10) NOT NULL default '1',
  broadcast tinyint(1) NOT NULL default '1',
  popmeson tinyint(1) NOT NULL default '0',
  user_active tinyint(1) default '1',
  user_session_time int(11) NOT NULL default '0',
  user_session_page smallint(5) NOT NULL default '0',
  user_lastvisit int(11) NOT NULL default '0',
  user_timezone tinyint(4) NOT NULL default '10',
  user_style tinyint(4) default NULL,
  user_lang varchar(255) NOT NULL default 'english',
  user_dateformat varchar(14) NOT NULL default 'D M d, Y g:i a',
  user_new_privmsg smallint(5) unsigned NOT NULL default '0',
  user_unread_privmsg smallint(5) unsigned NOT NULL default '0',
  user_last_privmsg int(11) NOT NULL default '0',
  user_emailtime int(11) default NULL,
  user_allowhtml tinyint(1) default '1',
  user_allowbbcode tinyint(1) default '1',
  user_allowsmile tinyint(1) default '1',
  user_allowavatar tinyint(1) NOT NULL default '1',
  user_allow_pm tinyint(1) NOT NULL default '1',
  user_allow_viewonline tinyint(1) NOT NULL default '1',
  user_notify tinyint(1) NOT NULL default '0',
  user_notify_pm tinyint(1) NOT NULL default '0',
  user_popup_pm tinyint(1) NOT NULL default '0',
  user_avatar_type tinyint(4) NOT NULL default '3',
  user_sig_bbcode_uid varchar(10) default NULL,
  user_actkey varchar(32) default NULL,
  user_newpasswd varchar(32) default NULL,
  user_group_cp int(11) NOT NULL default '2',
  user_active_cp enum('YES','NO') NOT NULL default 'YES',
  user_lastvisit_cp datetime NOT NULL default '0000-00-00 00:00:00',
  user_regdate_cp datetime NOT NULL default '0000-00-00 00:00:00',
  PRIMARY KEY  (user_id),
  KEY uid (user_id),
  KEY uname (username),
  KEY user_session_time (user_session_time),
  KEY user_session_time_2 (user_session_time)
) TYPE=MyISAM;


The Autoincrement value is not set in this table anywhere. What follows this code is just the list of users which ends on 235 at present.
Find all posts by Anonymous
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Tue Sep 16, 2003 6:05 am Reply with quoteBack to top

Modify the last line from
TYPE=MyISAM;
to
TYPE=MyISAM AUTO_INCREMENT=236;

If that errs, thenyou may need to update your version of phpMyAdmin because the syntax is correct.

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
Guest







PostPosted: Tue Sep 16, 2003 6:12 am Reply with quoteBack to top

I think i love you and want you to have my children! It worked! Very Happy
Find all posts by Anonymous
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Tue Sep 16, 2003 6:39 am Reply with quoteBack to top

Please, Please, assure me that you are a female Laughing

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
Guest







PostPosted: Tue Sep 16, 2003 6:42 am Reply with quoteBack to top

Sorry, im male, i was hoping the same as well. Nevermind, if i was gay id want to share some brother love with you! Razz

But as im not, ill just say thanks! Very Happy
Find all posts by Anonymous
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Tue Sep 16, 2003 7:51 am Reply with quoteBack to top

And I will just say You're Welcome!

_________________
Those who hear not the music think the dancers mad.
Raven Web Hosting|My Scripts & Stuff
Find all posts by RavenView user's profileSend private messageVisit poster's website
DrScares
Nuke Soldier
Nuke Soldier


Joined: Oct 23, 2003
Posts: 31

Location: Chicago

PostPosted: Sat Oct 25, 2003 10:22 am Reply with quoteBack to top

Interestingly enough, I'm suffering from this exact problem. The interesting thing is that my auto increment number for the user_id field is exactly the same as mentioned above.

What happened with me is I had to migrate a stand alone PHPBB2 board into the empty shell in PHPNuke 6.9.

After I did so, whenever a new user would attempt to register, in the Table, it would set their user_id as that ridiculous 217.... number so no one else could register. I read on another forum that someone else also had this problem who migrated their forums. The script I was using is from the Nuke UK website that can be found on that site.

I couldn't find how to switch the auto_increment, and I can't wait to try this method. So thanks for that Raven.

Here's my question though. What process of porting over data from two tables would result in the user_id being set to this number?
Find all posts by DrScaresView user's profileSend private messageSend e-mailVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
Raven
General
General


Joined: Mar 22, 2003
Posts: 5233

Location: USA

PostPosted: Sat Oct 25, 2003 11:32 am Reply with quoteBack to top

Here is one thread on my site that discusses this. There are others. It's a result of anonymous users having an id of -1. Hope this helps.

http://ravenphpscripts.com/posts280-highlightphpbb.html+increment
Find all posts by RavenView user's profileSend private messageVisit poster's website
Deako
Guest






PostPosted: Wed Nov 05, 2003 4:28 pm Reply with quoteBack to top

DrScares wrote:
Interestingly enough, I'm suffering from this exact problem. The interesting thing is that my auto increment number for the user_id field is exactly the same as mentioned above.

What happened with me is I had to migrate a stand alone PHPBB2 board into the empty shell in PHPNuke 6.9.

After I did so, whenever a new user would attempt to register, in the Table, it would set their user_id as that ridiculous 217.... number so no one else could register. I read on another forum that someone else also had this problem who migrated their forums. The script I was using is from the Nuke UK website that can be found on that site.

I couldn't find how to switch the auto_increment, and I can't wait to try this method. So thanks for that Raven.

Here's my question though. What process of porting over data from two tables would result in the user_id being set to this number?


Did you sort your problem out? My forum has worked a treat since!
Find all posts by Anonymous
DrScares
Nuke Soldier
Nuke Soldier


Joined: Oct 23, 2003
Posts: 31

Location: Chicago

PostPosted: Wed Nov 05, 2003 8:54 pm Reply with quoteBack to top

Yeah it ended up working! The only thing now is the memberlist data isn't sorted correctly, its all fudged up. Why? I don't know. But it won't sort correctly. Look here too see what I mean:

http://24.148.21.33:8080/main/modules.php?name=Members_List

_________________
"Woman was created for our destruction;
it is from woman that we inherit all our afflictions."
As quoted from Aramis in Alexandre Dumas' The Three Musketeers

-www.prime1now.com-
Find all posts by DrScaresView user's profileSend private messageSend e-mailVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
SaintPeter
Guest






PostPosted: Mon Nov 10, 2003 4:18 pm Reply with quoteBack to top

Bless you, Bless you all!

My Problem:
After an upgrade from phpBB to phpNuke, no new users could add.
The issue was that the "Autoindex" was set to 2147483647, the maximum value for (11*Cool^2. No new members could add once a user had the highest possible index.

Solution:
First, the "Anonymous" user has a user_id of -1. In "Twos complement", that is the same as the highest possible number in unsigned. So, you have to change this user_id to be 0 or 1. You also have to do this for the nuke_user_groups table as well.
Then, you can do this SQL command:
alter table `nuke_users` auto_increment = #

You must replace # with the current highest user_id+1
In my case, the line looked like this:
alter table `nuke_users` auto_increment = 720

Your milage may vary.

Thanks for the great insight. Thought I was going crazy.
Find all posts by Anonymous
Import
Nuke Cadet
Nuke Cadet


Joined: Nov 10, 2003
Posts: 1


PostPosted: Mon Nov 10, 2003 5:23 pm Reply with quoteBack to top

Im so confused..

http://www.usefcentral.net

I only have 6 users------
I changed TYPE=MyISAM AUTO_INCREMENT=9;

Max. number of accounts: -1

Now they get the activation then they click on it, it then goes to the home page but it's messed up and they still can't log in!


http://www.usefcentral.net/modules.php?name=Your_Account&op=activate&username=how&check_num=65a1fe245c2acebb361bfeeea49504ae


Iv tryed everything, i changed my Anonymous user id to 0.

But the user_id are messed up i think they skip #'s

Anonymous = 0
TK = 2
|ce = 4
BRAVO2 = 5
[IE] BIG LOU DOG = 6
Cataclysm = 7
AGM130 = 8
Find all posts by ImportView user's profileSend private message
mjrwoody
Nuke Cadet
Nuke Cadet


Joined: Nov 07, 2003
Posts: 1


PostPosted: Fri Nov 14, 2003 12:30 pm Reply with quoteBack to top

SaintPeter wrote:
Bless you, Bless you all!
Solution:
First, the "Anonymous" user has a user_id of -1. In "Twos complement", that is the same as the highest possible number in unsigned. So, you have to change this user_id to be 0 or 1. You also have to do this for the nuke_user_groups table as well.
Then, you can do this SQL command:
alter table `nuke_users` auto_increment = #

You must replace # with the current highest user_id+1
In my case, the line looked like this:
alter table `nuke_users` auto_increment = 720


Same issue here. I don't use nuke user groups, so i didn't have that table. Also, for newbies like me, in phpMyAdmin click on "nuke_users" then on "Operations", scroll to the bottom and change your "auto_increment" value here then click on "go"
Find all posts by mjrwoodyView user's profileSend private message
Death_of_Thought
Nuke Cadet
Nuke Cadet


Joined: Dec 03, 2003
Posts: 2


PostPosted: Wed Dec 03, 2003 2:08 am Reply with quoteBack to top

I have the same damned problem... however I cannot access PHPMYADMIN thingy, I use a modem.... could it just be the connection speed.... ? anyway I usually recieve an average of 2 new users per day, however nobody can register and thus at such a vital time in the site's life I need to fix this ASAP, okay now for the question: is there another way other than via phpmyadmin?

can I backup the database via the admin control panel and then edit it locally and then restore the backup?

I really need any help this is the first topic that I have found which describes my exact problem. I have nuke 6.9 I converted with the PHPBB to nuke script... I also have various other problems.

Is there a script for this or any alternatives?

_________________
“Insanity spawns infinity”
http://www.deathofthought.com
Intelligent discussion, free speech and bad spelling
Find all posts by Death_of_ThoughtView user's profileSend private messageVisit poster's website
Display posts from previous:      
This forum is locked: you cannot post, reply to, or edit topics.  This topic is locked: you cannot edit posts or make replies.printer-friendly view
View previous topic Log in to check your private messages View next topic
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.060 Seconds - 645 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::