You are missing our premiere tool bar navigation system! Register and use it for FREE!

NukeCops  
•  Home •  Downloads •  Gallery •  Your Account •  Forums • 
Readme First
- Readme First! -

Read and follow the rules, otherwise your posts will be closed
Modules
· Home
· FAQ
· Buy a Theme
· Advertising
· AvantGo
· Bookmarks
· Columbia
· Community
· Donations
· Downloads
· Feedback
· Forums
· PHP-Nuke HOWTO
· Private Messages
· Search
· Statistics
· Stories Archive
· Submit News
· Surveys
· Theme Gallery
· Top
· Topics
· Your Account
Who's Online
There are currently, 414 guest(s) and 0 member(s) that are online.

You are Anonymous user. You can register for free by clicking here
Nuke Cops :: View topic - Multiple Sites issue [ ]
 Forum FAQ  •  Search  •   •  Memberlist  •  Usergroups   •  Register  •  Profile •    •  Log in to check your private messages  •  Log in

 
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
Author Message
Sileencer
Nuke Soldier
Nuke Soldier


Joined: Nov 03, 2007
Posts: 10


PostPosted: Tue Dec 04, 2007 7:06 pm Reply with quoteBack to top

I'm trying to set up multiple sites. using the same database with different
prefixes but i want the User info to be the same.

So I tried several things, the first thing that came to mind was,
in Site1 config.php

Code:

$dbpass = "pepe";
$dbname = "pepe";
$prefix = "nuke";
$user_prefix = "nuke";
$dbtype = "MySQL";



On Site2 config

Code:

$dbpass = "pepe";
$dbname = "pepe";
$prefix = "sam";
$user_prefix = "nuke";
$dbtype = "MySQL";


Now I this this should have done the trick in my book, but it doesn't, I get all the same info on both sites, news, comments even a poll vote.

Ok, I did a little more digging around and in the manual it says to change only the user table to different name so here are the codes.. for the configs

Site1 config.php

Code:

$dbpass = "pepe";
$dbname = "pepe";
$prefix = "nuke";
$user_prefix = "wakala";
$dbtype = "MySQL";



Site2 config

Code:

$dbpass = "pepe";
$dbname = "pepe";
$prefix = "sam";
$user_prefix = "wakala";
$dbtype = "MySQL";


This didn't work at all in both sites I would get blank pages.. as if some error somewhere.

Any ideas with this ? I appreciate thanks..
Find all posts by SileencerView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Tue Dec 04, 2007 7:15 pm Reply with quoteBack to top

That should be working.
A blank page usually indicates an error. Enable error reporting and check your logs.

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Sileencer
Nuke Soldier
Nuke Soldier


Joined: Nov 03, 2007
Posts: 10


PostPosted: Tue Dec 04, 2007 7:34 pm Reply with quoteBack to top

Currently using 8.0

But I don't get it though the error occurs when i completely change the user_prefix to different name, If I change it to regular nuke it works

Code:


$prefix = "Sam";
$user_prefix = "nuke";



and if I change it it to this which I just realized

Code:


$prefix = "Sam";
$user_prefix = "Sam";



Original Stuff

I get the message of the Setup administrations

Its sorta off like User-prefix is overriding prefix.. it seems to me..


Also looking down into config i saw this..

Code:

$prefix = empty($user_prefix) ? $prefix : $user_prefix;




Could this be my issue..??
Find all posts by SileencerView user's profileSend private message
Evaders99
Site Admin
Site Admin


Joined: Aug 17, 2003
Posts: 12482


PostPosted: Tue Dec 04, 2007 8:59 pm Reply with quoteBack to top

Mmm that's weird. It's code that sets the $prefix to $user_prefix only if $user_prefix is defined. Kinda dumb to me.

Delete that line and it should work then

_________________
Helping those that help themselves
Read FIRST or DIE!

"Fighting is terrible, but not as terrible as losing the will to fight."
Star Wars Rebellion Network - Need Help? Evaders Squadron Coding
Find all posts by Evaders99View user's profileSend private messageVisit poster's websiteAIM Address
Sileencer
Nuke Soldier
Nuke Soldier


Joined: Nov 03, 2007
Posts: 10


PostPosted: Tue Dec 04, 2007 9:28 pm Reply with quoteBack to top

oh so that is what all that means.


Ok cool thank you very much I think it has work..

Thanks thanks again..
Find all posts by SileencerView user's profileSend private message
Display posts from previous:      
Post new topic  Reply to topicprinter-friendly view
View previous topic Log in to check your private messages View next topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group

Ported by Nuke Cops © 2003 www.nukecops.com
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::
Powered by TOGETHER TEAM srl ITALY http://www.togetherteam.it - DONDELEO E-COMMERCE http://www.DonDeLeo.com - TUTTISU E-COMMERCE http://www.tuttisu.it
Web site engine's code is Copyright © 2002 by PHP-Nuke. All Rights Reserved. PHP-Nuke is Free Software released under the GNU/GPL license.
Page Generation: 0.033 Seconds - 421 pages served in past 5 minutes. Nuke Cops Founded by Paul Laudanski (Zhen-Xjell)
:: FI Theme :: PHP-Nuke theme by coldblooded (www.nukemods.com) ::